summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-08-09 16:15:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-08-09 16:31:06 +0200
commit448052b713ba7016490de02cea7b6acf2211006f (patch)
tree11092a6789c4cc41ae9ff1c2293d236b837bd3c8 /gnu
parent18f5d2a70a8fb99e7435c47efcbe12602b6b415e (diff)
downloadguix-448052b713ba7016490de02cea7b6acf2211006f.tar.gz
gnu: libgdata: Disable failing tests.
* gnu/packages/gnome.scm (libgdata)[arguments]: Add ‘disable-failing-tests’
phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ed4def65b5..d7c29dc990 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -345,6 +345,13 @@ formats like PNG, SVG, PDF and EPS.")
              ;; The ca-certificates.crt is not available in the build
              ;; environment.
              (setenv "SSL_CERT_FILE" "/dev/null")
+             #t))
+         (add-before 'check 'disable-failing-tests
+           (lambda _
+             ;; The PicasaWeb API tests fail with gnome-online-accounts@3.24.2.
+             ;; They have been removed in libgdata 0.17.6, so just do the same.
+             (substitute* "gdata/tests/Makefile"
+               (("picasaweb\\$\\(EXEEXT\\) ") ""))
              #t)))))
     (native-inputs
      `(("glib:bin" ,glib "bin")