summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-09 02:57:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-15 17:03:14 +0200
commit453aae663b9f601093755f4fa89a342a361c6ded (patch)
treef234fcb05127da8ad63ef0cbe7183f9635ac3c30 /gnu
parent9e99b1b41ba007124861092ad4bd0995e25abd2a (diff)
downloadguix-453aae663b9f601093755f4fa89a342a361c6ded.tar.gz
gnu: Add texlive-generic-tex-ini-files.
* gnu/packages/tex.scm (texlive-generic-tex-ini-files): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7e4d29be53..b798590fe7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -291,6 +291,40 @@ bundle.")
     ;; under LPPL.
     (license (list license:expat license:lppl))))
 
+(define-public texlive-generic-tex-ini-files
+  (package
+    (name "texlive-generic-tex-ini-files")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (svn-reference
+                    (url (string-append "svn://www.tug.org/texlive/tags/"
+                                        %texlive-tag "/Master/texmf-dist/"
+                                        "/tex/generic/tex-ini-files"))
+                    (revision %texlive-revision)))
+              (sha256
+               (base32
+                "1wh42n1lmzcvi3g6mm31nm3yd5ha5bl260xqc444jg1m9fdp3wz5"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+         (let ((target (string-append (assoc-ref %outputs "out")
+                                      "/share/texmf-dist/tex/generic/tex-ini-files")))
+           (mkdir-p target)
+           (copy-recursively (assoc-ref %build-inputs "source") target)
+           #t))))
+    (home-page "http://ctan.org/pkg/tex-ini-files")
+    (synopsis "Files for creating TeX formats")
+    (description "This bundle provides a collection of model \".ini\" files
+for creating TeX formats.  These files are commonly used to introduced
+distribution-dependent variations in formats.  They are also used to
+allow existing format source files to be used with newer engines, for example
+to adapt the plain e-TeX source file to work with XeTeX and LuaTeX.")
+    (license license:public-domain)))
+
 (define texlive-texmf
   (package
    (name "texlive-texmf")