summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-02 14:30:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-02 14:32:03 +0300
commit45c6abaef5297b2bb76182eacb632739043a2cf3 (patch)
tree5519cc969f20c99d76cab1d207fea094e9e92abc /gnu
parentb62c9fbdd3f706f8bcf70d92807184e507603ec5 (diff)
downloadguix-45c6abaef5297b2bb76182eacb632739043a2cf3.tar.gz
gnu: inkscape: Skip some tests on riscv64-linux.
* gnu/packages/inkscape.scm (inkscape)[arguments]: Use the custom
'disable-more-tests phase on riscv64-linux also.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/inkscape.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 2840fd789b..aa2c6419a0 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -194,7 +194,8 @@ endif()~%~%"
                 (("text-glyphs-vertical") "")
                 (("test-rtl-vertical") ""))))
           ,@(if (or (target-aarch64?)
-                    (target-ppc64le?))
+                    (target-ppc64le?)
+                    (target-riscv64?))
               `((add-after 'unpack 'disable-more-tests
                   (lambda _
                     ;; https://gitlab.com/inkscape/inkscape/-/issues/3554#note_1035680690