summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-05-10 12:27:42 -0400
committerKei Kebreau <kei@openmailbox.org>2017-05-10 19:55:47 -0400
commit45f8e7f75e5401eb05bf98383ee169f6b7f06851 (patch)
tree6548bae44471d467115d8a2153584c6ff264192e /gnu
parentbc0e6c9312f5f755e1ccd7d8c43b58974e6f7d38 (diff)
downloadguix-45f8e7f75e5401eb05bf98383ee169f6b7f06851.tar.gz
gnu: Add python-sge-pygame.
* gnu/packages/game-development.scm (python-sge-pygame, python2-sge-pygame):
New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 41d85aac87..75ab59b1b3 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -187,6 +187,33 @@ and network communications.  A very thin client library can be embedded to
 provide connectivity for client applications written in any language.")
     (license license:gpl3+)))
 
+(define-public python-sge-pygame
+  (package
+    (name "python-sge-pygame")
+    (version "1.4.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sge-pygame" version))
+       (sha256
+        (base32
+         "1qhrcja1igqkjjn1w425ni5f41mijdq5dpq0ymkhl29xxrf8hnx8"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pygame" ,python-pygame)
+       ("python-six" ,python-six)))
+    (home-page "http://stellarengine.nongnu.org")
+    (synopsis "2D game engine for Python")
+    (description
+     "The SGE Game Engine (\"SGE\", pronounced like \"Sage\") is a
+general-purpose 2D game engine.  It takes care of several details fro you so
+you can focus on the game itself.  This makes more rapid game development
+possible, and it also makes the SGE easy to learn.")
+    (license license:lgpl3+)))
+
+(define-public python2-sge-pygame
+  (package-with-python2 python-sge-pygame))
+
 (define-public tiled
   (package
     (name "tiled")