summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-28 09:18:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-28 09:18:29 +0200
commit460a38976a03f75f0902677da66e11e3322620ef (patch)
tree14cce3bcf685916f9204b1f4db272b081191cce0 /gnu
parentf43a7838716b80e439d1d94c00da6880d6f2893f (diff)
downloadguix-460a38976a03f75f0902677da66e11e3322620ef.tar.gz
gnu: uncrustify: Update to 0.74.0.
* gnu/packages/code.scm (uncrustify): Update to 0.74.0.
[native-inputs]: Remove unzip.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/code.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 29479cae54..9bc9771dc1 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -746,7 +746,7 @@ independent targets.")
 (define-public uncrustify
   (package
     (name "uncrustify")
-    (version "0.69.0")
+    (version "0.74.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -755,11 +755,10 @@ independent targets.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0sqrg13kp8fwymq40976bq380bzw40g4ss7ihlbq45d0f90ifa1k"))))
+                "0v48vhmzxjzysbf0vhxzayl2pkassvbabvwg84xd6b8n5i74ijxd"))))
     (build-system cmake-build-system)
     (native-inputs
-     `(("unzip" ,unzip)
-       ("python" ,python-wrapper)))
+     `(("python" ,python-wrapper)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases