summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-19 13:09:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:41 +0200
commit46243555130d4533a9266861e84914544e7846ea (patch)
tree33ad9b55597cc13d9e7b776e29a67f59fa85e3fd /gnu
parentf66f05e171a59177f3d242809b4eb52ee96dbcaa (diff)
downloadguix-46243555130d4533a9266861e84914544e7846ea.tar.gz
gnu: hyperfine: Prepare for cross-compiling.
* gnu/packages/rust-apps.scm (hyperfine)[arguments]: Don't install the
sources.  Adjust the custom 'install-more phase to search for the shell
completions anywhere in the target directory.

Change-Id: I067c40e06e145297ceb0eb5127bdd7835033750a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rust-apps.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 0fcb2f0fdb..158d126321 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -701,6 +701,7 @@ characters, ASCII whitespace characters, other ASCII characters and non-ASCII.")
      `(#:modules ((guix build cargo-build-system)
                   (guix build utils)
                   (srfi srfi-26))
+       #:install-source? #f
        #:cargo-inputs
        (("rust-atty" ,rust-atty-0.2)
         ("rust-cfg-if" ,rust-cfg-if-0.1)
@@ -730,13 +731,13 @@ characters, ASCII whitespace characters, other ASCII characters and non-ASCII.")
                    (zsh   (string-append share "zsh/site-functions")))
               (install-file "doc/hyperfine.1" man)
               (for-each (cut install-file <> bash)
-                        (find-files "target/release/build" "^hyperfine.bash$"))
+                        (find-files "target" "^hyperfine.bash$"))
               (rename-file (string-append bash "/hyperfine.bash")
                            (string-append bash "/hyperfine"))
               (for-each (cut install-file <> fish)
-                        (find-files "target/release/build" "^hyperfine.fish$"))
+                        (find-files "target" "^hyperfine.fish$"))
               (for-each (cut install-file <> zsh)
-                        (find-files "target/release/build" "^_hyperfine$"))))))))
+                        (find-files "target" "^_hyperfine$"))))))))
     (home-page "https://github.com/sharkdp/hyperfine")
     (synopsis "Command-line benchmarking tool")
     (description