summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorpinoaffe@airmail.cc <pinoaffe@airmail.cc>2020-11-22 17:55:11 +0000
committerChristopher Baines <mail@cbaines.net>2020-11-28 13:09:08 +0000
commit466a9de119886cd94eefad1bac4b441358d76ad7 (patch)
tree3036540ca29927c302e0ff6782b08cc1d4e65834 /gnu
parent1a3233f074ddd9a607860256b0ec582b0717ec69 (diff)
downloadguix-466a9de119886cd94eefad1bac4b441358d76ad7.tar.gz
gnu: Add python-flask-markdown.
* gnu/packages/python-web.scm (python-flask-markdown): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f5ffc2e0f0..5cb974ddc1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -984,6 +984,32 @@ both of which are installed automatically if you install this library.")
 Origin Resource Sharing}, making cross-origin AJAX possible.")
     (license license:expat)))
 
+(define-public python-flask-markdown
+  (package
+    (name "python-flask-markdown")
+    (version "0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Flask-Markdown" version))
+       (sha256
+        (base32
+         "0l32ikv4f7va926jlq4f7gx0xid247bhlxl6bd9av5dk8ljz1hyq"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:tests? #f))        ; Tests seem to be incompatible with latest python
+    (propagated-inputs
+     `(("python-markdown" ,python-markdown)
+       ("python-flask" ,python-flask)))
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (home-page "https://github.com/dcolish/flask-markdown")
+    (synopsis "Small extension to help with using Markdown in Flask")
+    (description
+     "Flask-Markdown supports several extensions for Markdown and integrates
+into Jinja2 by default.")
+    (license license:bsd-3)))
+
 (define-public python-html5lib
   (package
     (name "python-html5lib")