summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-26 23:45:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:35:15 +0100
commit46781c3008825a3e9c0b69c313bc16037140596b (patch)
treefa0bc3efc68989891c1cc1fc17896cf9571d8ee7 /gnu
parent67da8cac76fe2360fc62868b0de0f3fcdf90728a (diff)
downloadguix-46781c3008825a3e9c0b69c313bc16037140596b.tar.gz
gnu: go-github-com-go-asn1-ber-asn1-ber: Move to golang-crypto.
* gnu/packages/syncthing.scm (go-github-com-go-asn1-ber-asn1-ber): Move
from here ...
* gnu/packages/golang-crypto.scm: ... to here.

Change-Id: Ib146ac76bbd2d7c34c315dc4f424d05ced597011
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-crypto.scm30
-rw-r--r--gnu/packages/syncthing.scm22
2 files changed, 27 insertions, 25 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index baf68b7089..047b8c470a 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
 ;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
@@ -11,16 +12,15 @@
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
-;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2022, 2023 Nicolas Graves <ngraves@ngraves.fr>
-;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
 ;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
 ;;; Copyright © 2023 Jack Hill <jackhill@jackhill.us>
-;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -454,6 +454,30 @@ providing bidirectional mapping values to their names, plus enum convenience
 for values.")
     (license license:bsd-3)))
 
+(define-public go-github-com-go-asn1-ber-asn1-ber
+  (package
+    (name "go-github-com-go-asn1-ber-asn1-ber")
+    (version "1.5.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/go-asn1-ber/asn1-ber")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15ygmfmdwwjda9xdq58rx6gnmsfc14m1qqhcj7cn7rm0mx4wk2vb"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/go-asn1-ber/asn1-ber"))
+    (home-page "https://github.com/go-asn1-ber/asn1-ber")
+    (synopsis "ASN.1 BER encoding and decoding in Go")
+    (description
+     "This package provides ASN.1 BER encoding and decoding in the
+Go language.")
+    (license license:expat)))
+
 (define-public go-github-com-golang-jwt-jwt
   (package
     (name "go-github-com-golang-jwt-jwt")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5b45be6dc1..0700f1a258 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -491,28 +491,6 @@ message streaming.")
     (home-page "https://github.com/matttproud/golang_protobuf_extensions")
     (license asl2.0)))
 
-(define-public go-github-com-go-asn1-ber-asn1-ber
-  (package
-    (name "go-github-com-go-asn1-ber-asn1-ber")
-    (version "1.5.3")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://github.com/go-asn1-ber/asn1-ber")
-                     (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "15ygmfmdwwjda9xdq58rx6gnmsfc14m1qqhcj7cn7rm0mx4wk2vb"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/go-asn1-ber/asn1-ber"))
-    (synopsis "ASN.1 BER encoding and decoding in Go")
-    (description "This package provides ASN.1 BER encoding and decoding in the
-Go language.")
-    (home-page "https://github.com/go-asn1-ber/asn1-ber")
-    (license expat)))
-
 (define-public go-github-com-go-ldap-ldap
   (package
     (name "go-github-com-go-ldap-ldap")