summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-12-07 08:55:52 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-08 10:47:21 +0100
commit46aa8729f3c7b284d3153aef36b0884bfbc27006 (patch)
tree21b7eff05c2c49eae299d57259642ebf27d5d82b /gnu
parenta5e83ab96beb1347693dde810d83e25298e5d28d (diff)
downloadguix-46aa8729f3c7b284d3153aef36b0884bfbc27006.tar.gz
gnu: openrct2: Always install libraries to /lib.
* gnu/packages/games.scm (openrct2)[arguments]: Add #:configure-flags argument
to force installing libraries to /lib.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a699fadc2a..524572b99a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2731,6 +2731,9 @@ Transport Tycoon Deluxe.")
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f ;; no tests available
+       #:configure-flags
+        (list (string-append "-DCMAKE_INSTALL_LIBDIR="
+                       (assoc-ref %outputs "out") "/lib"))
        #:phases
         (modify-phases %standard-phases
           (add-after 'unpack 'fix-usr-share-paths