summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-04 11:27:39 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-04 11:29:41 +0200
commit4702cec24637fc9cb5ed544817d56e9770b21ebf (patch)
tree7682a8489e79a1928fbda6d74697904ee17ca99a /gnu
parenta73956baf4d1f103fbb574c5f0880e10de1c027b (diff)
downloadguix-4702cec24637fc9cb5ed544817d56e9770b21ebf.tar.gz
gnu: bamtools: Set rpath via LDFLAGS.
* gnu/packages/bioinformatics.scm (bamtools): Add a pre-configure phase
  setting $LDFLAGS to set the rpath to $out/lib/bamtools.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8bc5b868ec..7dc1bc48ce 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -62,7 +62,17 @@
                (base32
                 "1brry29bw2xr2l9pqn240rkqwayg85b8qq78zk2zs6nlspk4d018"))))
     (build-system cmake-build-system)
-    (arguments `(#:tests? #f)) ;no "check" target
+    (arguments
+     `(#:tests? #f ;no "check" target
+       #:phases
+       (modify-phases %standard-phases
+         (add-before
+          'configure 'set-ldflags
+          (lambda* (#:key outputs #:allow-other-keys)
+            (setenv "LDFLAGS"
+                    (string-append
+                     "-Wl,-rpath="
+                     (assoc-ref outputs "out") "/lib/bamtools")))))))
     (inputs `(("zlib" ,zlib)))
     (home-page "https://github.com/pezmaster31/bamtools")
     (synopsis "C++ API and command-line toolkit for working with BAM data")