summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-11 00:22:50 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-11 00:23:16 +0100
commit472fc855bce77cfc4157e65763db06a066257129 (patch)
tree3a66822a988e0b3ee79404a29aefcd6ab9c682c9 /gnu
parent2c5ab05bffe5f89092ef60c3743b3941dcf92af0 (diff)
downloadguix-472fc855bce77cfc4157e65763db06a066257129.tar.gz
gnu: Add guile-aspell.
* gnu/packages/guile.scm (guile-aspell): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index f712514285..eca9c99106 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -28,6 +28,7 @@
 (define-module (gnu packages guile)
   #:use-module (guix licenses)
   #:use-module (gnu packages)
+  #:use-module (gnu packages aspell)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages gawk)
@@ -1347,4 +1348,40 @@ an abstraction over raw memory.  It's also more powerful than the C
 type system, elevating types to first-class status.")
     (license gpl3+)))
 
+(define-public guile-aspell
+  (package
+    (name "guile-aspell")
+    (version "0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://lonelycactus.com/tarball/guile_aspell-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1wknn57x2qcsbn7zw6sbn1ma6fjsg8cvpnf78ak47s8jw6k6j75n"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags (list (string-append "--with-guilesitedir="
+                                              (assoc-ref %outputs "out")
+                                              "/share/guile/site/2.0"))
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'set-libaspell-file-name
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (let ((aspell (assoc-ref inputs "aspell")))
+                        (substitute* "aspell/aspell.scm"
+                          (("\"libaspell\\.so\"")
+                           (string-append "\"" aspell
+                                          "/lib/libaspell\"")))
+                        #t))))))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("guile" ,guile-2.0)
+              ("aspell" ,aspell)))
+    (home-page "https://github.com/spk121/guile-aspell")
+    (synopsis "Spell-checking from Guile")
+    (description
+     "guile-aspell is a Guile Scheme library for comparing a string against a
+dictionary and suggesting spelling corrections.")
+    (license gpl3+)))
+
 ;;; guile.scm ends here