summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-21 13:32:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-21 16:55:56 +0200
commit4733c76c555f2e5a9b2c71d70b5e4ae8b351d3e8 (patch)
tree371a7dcdfa13ab06073f114330b1aecb3951ffef /gnu
parent5356cec68b9b7b5478d7df542c6a8fc70226b878 (diff)
downloadguix-4733c76c555f2e5a9b2c71d70b5e4ae8b351d3e8.tar.gz
gnu: yadifa: Update to 2.4.0.
* gnu/packages/dns.scm (yadifa): Update to 2.4.0.
[arguments]: Remove obsolete #:configure-flags.

s update
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/dns.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 9d7da2fa0a..cd809fa9b9 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -760,16 +760,16 @@ served by AS112.  Stub and forward zones are supported.")
 (define-public yadifa
   (package
     (name "yadifa")
-    (version "2.3.11")
+    (version "2.4.0")
     (source
-     (let ((build "9779"))
+     (let ((build "9809"))
        (origin
          (method url-fetch)
          (uri
           (string-append "https://www.yadifa.eu/sites/default/files/releases/"
                          "yadifa-" version "-" build ".tar.gz"))
          (sha256
-          (base32 "10zj0dp99n15mjpdydpvhj29vif6s31plkpkyflh0wjmcn2536jg")))))
+          (base32 "114a1y4pzzzq0s9hyn65nd4fg19xijsqpfhsd0wkvjndsazg63ky")))))
     (build-system gnu-build-system)
     (native-inputs
      `(("which" ,which)))
@@ -786,15 +786,8 @@ served by AS112.  Stub and forward zones are supported.")
        #:configure-flags
        (list "--sysconfdir=/etc"
              "--localstatedir=/var"
-             "--disable-build-timestamp" ; build reproducibly
-             "--enable-shared"
-             "--disable-static"
-             "--enable-acl"
-             "--enable-caching"
-             "--enable-ctrl"            ; enable remote control
-             "--enable-nsec"
-             "--enable-nsec3"
-             "--enable-tsig")))
+             "--enable-shared" "--disable-static"
+             "--disable-build-timestamp"))) ; build reproducibly
     (home-page "https://www.yadifa.eu/")
     (synopsis "Authoritative DNS name server")
     (description "YADIFA is an authoritative name server for the @dfn{Domain