summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-26 11:19:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-26 12:06:57 -0400
commit474d3ef643b68e885fba1f685ebdf04d5aa78bcb (patch)
tree98ce3b80a64782821d16c1527301583df3168b46 /gnu
parent0ea2b720596126c942d198af5f2de74147784d98 (diff)
downloadguix-474d3ef643b68e885fba1f685ebdf04d5aa78bcb.tar.gz
gnu: qemu: Disable qtest-aarch64/migration-test test.
* gnu/packages/patches/qemu-disable-aarch64-migration-test.patch: Add patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/virtualization.scm (qemu): Apply it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/qemu-disable-aarch64-migration-test.patch13
-rw-r--r--gnu/packages/virtualization.scm1
3 files changed, 15 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4e982dc6e3..9b3b199c7c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1749,6 +1749,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/python-werkzeug-tests.patch		\
   %D%/packages/patches/python-zeep-Fix-pytest_httpx-test-cases.patch	\
   %D%/packages/patches/qemu-build-info-manual.patch		\
+  %D%/packages/patches/qemu-disable-aarch64-migration-test.patch	\
   %D%/packages/patches/qemu-glibc-2.27.patch 			\
   %D%/packages/patches/qemu-glibc-2.30.patch 			\
   %D%/packages/patches/qemu-fix-agent-paths.patch 		\
diff --git a/gnu/packages/patches/qemu-disable-aarch64-migration-test.patch b/gnu/packages/patches/qemu-disable-aarch64-migration-test.patch
new file mode 100644
index 0000000000..bf60ed23bb
--- /dev/null
+++ b/gnu/packages/patches/qemu-disable-aarch64-migration-test.patch
@@ -0,0 +1,13 @@
+Disable the qtest-aarch64/migration-test, which sometimes fail non-deterministically.
+See: https://gitlab.com/qemu-project/qemu/-/issues/1230.
+
+--- qemu-7.1.0/tests/qtest/meson.build.old	1969-12-31 19:00:01.000000000 -0500
++++ qemu-7.1.0/tests/qtest/meson.build	2022-09-26 11:11:05.434209797 -0400
+@@ -219,7 +219,6 @@
+   ['arm-cpu-features',
+    'numa-test',
+    'boot-serial-test',
+-   'migration-test',
+    'bcm2835-dma-test']
+ 
+ qtests_s390x = \
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 199156dbb9..e14549dcd1 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -169,6 +169,7 @@
         (base32
          "1rmvrgqjhrvcmchnz170dxvrrf14n6nm39y8ivrprmfydd9lwqx0"))
        (patches (search-patches "qemu-build-info-manual.patch"
+                                "qemu-disable-aarch64-migration-test.patch"
                                 "qemu-fix-agent-paths.patch"))
        (modules '((guix build utils)))
        (snippet