summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-12 23:46:54 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-13 00:57:15 +0200
commit47986cc8e95a1c0ed69ded62d6aeca1e82068cd6 (patch)
tree9adf528d1fec940e3760c28399ce98e5009a6731 /gnu
parent12bcfcedb062c4ed89efd51da719df70e2f428b1 (diff)
downloadguix-47986cc8e95a1c0ed69ded62d6aeca1e82068cd6.tar.gz
gnu: libupnp: Update to 1.12.1.
* gnu/packages/upnp.scm (libupnp): Update to 1.12.1.
[source]: Change to URL-FETCH with bootstrapped tarball.
[native-inputs]: Remove AUTOCONF, AUTOMAKE, and LIBTOOL.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/upnp.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index 25b73189bc..38ddfd05b7 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -94,21 +94,17 @@ over IRC, instant messaging, network games, and most server software.")
 (define-public libupnp
   (package
     (name "libupnp")
-    (version "1.8.6")
+    (version "1.12.1")
     (source
      (origin
-      (method git-fetch)
-      (uri (git-reference
-            (url "https://github.com/pupnp/pupnp.git")
-            (commit (string-append "release-" version))))
+      (method url-fetch)
+      (uri (string-append "https://github.com/pupnp/pupnp/releases/download"
+                          "/release-" version "/libupnp-" version".tar.bz2"))
       (sha256
        (base32
-        "1jlb6qh47513h2simy0zxia5q61w1c31mnwmjqpr2nf832lmnpk4"))))
-       (native-inputs
-        `(("autoconf" ,autoconf)
-          ("automake" ,automake)
-          ("libtool" ,libtool)
-          ("pkg-config" ,pkg-config)))
+        "02a0dnbk1cla8xlb5l2zp09grv2hsf8n4jbd560mmzj830mn8dpw"))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
     (build-system gnu-build-system)
     (arguments
      ;; The tests require a network device capable of multicasting which is