summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-03-25 03:22:13 -0700
committerLudovic Courtès <ludo@gnu.org>2023-06-09 23:07:12 +0200
commit48812c85dd62ea8c075a606913bd7ae77c50c047 (patch)
tree0dbdea0e87455f5c171e1fdc976ce6ef61d608a5 /gnu
parent71c2f02ba057ce4a14cfdb8b665fa17c70eaa664 (diff)
downloadguix-48812c85dd62ea8c075a606913bd7ae77c50c047.tar.gz
gnu: obs-websocket: Deprecate in favor of "obs".
* gnu/packages/video.scm (obs-websocket): Rewrite as a deprecated alias
for "obs".

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm36
1 files changed, 2 insertions, 34 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3b6af31b76..6f0a6e6ad9 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3476,40 +3476,8 @@ and JACK.")
     (license license:gpl2+)))
 
 (define-public obs-websocket
-  (package
-    (name "obs-websocket")
-    (version "4.9.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/Palakis/obs-websocket")
-             (commit version)
-             (recursive? #t)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0giwhm0rbc578qng4invqqma935zzjlf05msz1gx986aqk654s7k"))))
-    (build-system cmake-build-system)
-    (arguments
-     `(#:tests? #f                      ;no tests
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'remove-permission-change
-           (lambda* _
-             (substitute* "CMakeLists.txt"
-               ;; Remove lines that set writeable permissions on outputs.
-               (("PERMISSIONS [^)]*") "")
-               (("set\\(CMAKE_INSTALL_DEFAULT_DIRECTORY_PERMISSIONS") "")
-               ;; Ug^WClever hack to comment out the next line, which is ‘)’.
-               (("(OWNER|GROUP|WORLD)_READ .*") "#")))))))
-    (inputs
-     (list obs qtbase-5))
-    (home-page "https://github.com/Palakis/obs-websocket")
-    (synopsis "OBS plugin for remote control via WebSockets")
-    (description "This OBS plugin allows you to establish a WebSocket channel
-from within your running OBS instance so that you can control it remotely from
-programs on your current machine or on other machines.")
-    (license license:gpl2+)))
+  ;; Functionality was merged into OBS.
+  (deprecated-package "obs-websocket" obs))
 
 (define-public obs-wlrobs
   (package