summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-01 21:29:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-01 22:21:51 +0200
commit48949bf4e0bd8331209a6d6f5a301d9f0fecf15e (patch)
tree806319775c3eb2fdd84359dc85250958a17ee319 /gnu
parentca76da801222caecc48aecfedc839c48fec8b7d0 (diff)
downloadguix-48949bf4e0bd8331209a6d6f5a301d9f0fecf15e.tar.gz
gnu: emacs-clj-refactor: Update to 3.9.1.
* gnu/packages/emacs-xyz.scm (emacs-clj-refactor): Update to 3.9.1.
[propagated-inputs]: Re-order alphabetically.
[description]: Use proper capitalization and remove unnecessary hyphens.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6a9348a53b..bcca22820d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12778,7 +12778,7 @@ Clojure projects from templates.")
 (define-public emacs-clj-refactor
   (package
     (name "emacs-clj-refactor")
-    (version "3.7.0")
+    (version "3.9.1")
     (source
      (origin
        (method git-fetch)
@@ -12787,15 +12787,21 @@ Clojure projects from templates.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0nwc4c8cn9mj9x7fsjx1m34rma5qq87d611j7w02kfa7yhbj0vwk"))))
+        (base32 "1c7ndc81j3pljgf7n188f3mm6vm3gyiplh4mnb4y5wbkbnpiwgdc"))))
     (build-system emacs-build-system)
     (propagated-inputs
-     (list emacs-yasnippet emacs-paredit emacs-multiple-cursors emacs-cider
-           emacs-clojure-mode emacs-parseedn emacs-hydra emacs-inflections))
+     (list emacs-cider
+           emacs-clojure-mode
+           emacs-hydra
+           emacs-inflections
+           emacs-multiple-cursors
+           emacs-paredit
+           emacs-parseedn
+           emacs-yasnippet))
     (home-page "https://github.com/clojure-emacs/clj-refactor.el")
     (synopsis "Powerful refactoring functionality for Clojure projects")
     (description "This Emacs package complements the refactoring functionality
-you'd find in clojure-mode and CIDER.")
+you'd find in Clojure mode and CIDER.")
     (license license:gpl3+)))
 
 (define-public emacs-clojure-snippets