summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-03-12 23:00:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-03-15 20:18:43 +0100
commit4989e09cc0bc07554494101fde098d01854d6eca (patch)
tree332a6e14c9daf714485dec46a28521d10c489a05 /gnu
parent70c8a412f6f76101c88d4e1bf75f2994c5724bb3 (diff)
downloadguix-4989e09cc0bc07554494101fde098d01854d6eca.tar.gz
gnu: Add r-fstcore.
* gnu/packages/cran.scm (r-fstcore): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 094bb70341..fbab934063 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8038,6 +8038,27 @@ promises, but with a syntax that is idiomatic R.")
 using the @code{snow} package.")
     (license license:gpl2)))
 
+(define-public r-fstcore
+  (package
+    (name "r-fstcore")
+    (version "0.9.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "fstcore" version))
+       (sha256
+        (base32 "1qicjwsm87wgjm5mxrsgi697fmcfz6wyqcxfgngwxrf8kq4awjsf"))))
+    (properties `((upstream-name . "fstcore")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rcpp))
+    (home-page "https://www.fstpackage.org/fstcore/")
+    (synopsis "R bindings to the fstlib library")
+    (description
+     "The fstlib library provides multithreaded serialization of compressed
+data frames using the fst format.  The fst format allows for random access of
+stored data and compression with the LZ4 and ZSTD compressors.")
+    (license license:mpl2.0)))
+
 (define-public r-fst
   (package
     (name "r-fst")