summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-09-09 17:50:07 -0700
committerLeo Famulari <leo@famulari.name>2021-09-09 21:34:41 -0400
commit49c6145b97066bff959cfc882cf2a658fbd0cb53 (patch)
treef132858b1ae0e3e5cc152b34b4b950bb8da7672c /gnu
parent173b6f6f154ab214b89f063ff3a67ea3207347ec (diff)
downloadguix-49c6145b97066bff959cfc882cf2a658fbd0cb53.tar.gz
gnu: go-github-com-keybase-go-ps: Fix tests when building with Go 1.17.
* gnu/packages/golang.scm (go-github-com-keybase-go-ps)[arguments]
<#:phases>{fix-tests}: Remove extraneous build line to appease go@1.17.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2dfd47d396..4577c49cba 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1597,7 +1597,9 @@ Go.")
                  (("/bin/sleep" command)
                   (string-append
                    (assoc-ref (or native-inputs inputs) "coreutils")
-                   command))))))))
+                   command)))
+               (substitute* "src/github.com/keybase/go-ps/process_openbsd.go"
+                 (("^// \\+build ignore") "")))))))
       (native-inputs
        `(("coreutils" ,coreutils)
          ("go-github-com-stretchr-testify"