summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorM <matf@disr.it>2022-09-15 22:38:01 +0200
committerChristopher Baines <mail@cbaines.net>2022-09-16 12:19:49 +0200
commit49e120272bf525793406916457b1c225a6dfef38 (patch)
tree90ea089efd935aa8bdd41f35adab93c675e50189 /gnu
parent39b21d388aaf8e1dfa5e9763fe63d5d14aa12cd7 (diff)
downloadguix-49e120272bf525793406916457b1c225a6dfef38.tar.gz
gnu: Add python-syllables.
* gnu/packages/python-xyz.scm (python-syllables): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e22d9dc87e..de3fc1791d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -128,6 +128,7 @@
 ;;; Copyright © 2022 Marek Felšöci <marek@felsoci.sk>
 ;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -10032,6 +10033,24 @@ function signatures.")
      "This package provides a YAML template engine with Python expressions.")
     (license license:expat)))
 
+(define-public python-syllables
+  (package
+    (name "python-syllables")
+    (version "1.0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "syllables" version))
+              (sha256
+               (base32
+                "0wkl6h0rg6fbsxfp0a8fnibf3l4l6lbh6z12cvcilgb6qhxzpmv3"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/prosegrinder/python-syllables")
+    (synopsis "Package for estimating the number of syllables in a word")
+    (description
+     "This package provides a Python package for estimating the number of
+syllables in a word.")
+    (license license:gpl3)))
+
 (define-public python-sympy
   (package
     (name "python-sympy")