summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2016-11-11 10:43:24 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-12 13:04:45 +0100
commit4a38422157d1dcf8505734b818f6c21ffe12c48a (patch)
treeeda8b0752ec0681d4af76c2b68c1a146512b56e8 /gnu
parente32171eeeb4baef781dac797a76fee100a802a3d (diff)
downloadguix-4a38422157d1dcf8505734b818f6c21ffe12c48a.tar.gz
gnu: prosody: fix SSL/TLS.
* gnu/packages/lua.scm (lua5.1-sec-0.5): New variable.
* gnu/packages/messaging.scm (prosody):
[inputs]: Change lua5.1-sec to lua5.1-sec-0.5.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lua.scm13
-rw-r--r--gnu/packages/messaging.scm4
2 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index fe0ec208aa..f95da3587d 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
+;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -280,6 +281,18 @@ communication.  It takes an already established TCP connection and creates a
 secure session between the peers.")
     (license (package-license lua-5.1))))
 
+(define-public lua5.1-sec-0.5
+  (package
+    (inherit lua5.1-sec)
+    (version "0.5.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/brunoos/luasec/archive/"
+                                  "luasec-" version ".tar.gz"))
+              (sha256
+               (base32
+                "01llf5bcrjmqqy6m65avqkajz7h79rvkka6rd131kwr10n75yp3d"))))))
+
 (define-public lua-lgi
   (package
     (name "lua-lgi")
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 66cf231cfb..72b89067f0 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 ng0 <ngillmann@runbox.com>
 ;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
+;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -563,7 +564,8 @@ end-to-end encryption support; XML console.")
        ("lua5.1-expat" ,lua5.1-expat)
        ("lua5.1-socket" ,lua5.1-socket)
        ("lua5.1-filesystem" ,lua5.1-filesystem)
-       ("lua5.1-sec" ,lua5.1-sec)))
+       ;; See <https://prosody.im/doc/depends#luasec>.
+       ("lua5.1-sec" ,lua5.1-sec-0.5)))
     (home-page "https://prosody.im/")
     (synopsis "Jabber (XMPP) server")
     (description "Prosody is a modern XMPP communication server.  It aims to