summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-06-30 19:47:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-06-30 19:47:43 +0200
commit4b2a2161a5705a577dbc20497ffd94ac160de9f4 (patch)
tree7cfb146c8ef49e2ed3ee47128001f326b1320734 /gnu
parent023ff651462f70004c7a92b19fd072ee3138e5a2 (diff)
downloadguix-4b2a2161a5705a577dbc20497ffd94ac160de9f4.tar.gz
gnu: opensmtpd: Update to 7.3.0p1.
* gnu/packages/mail.scm (opensmtpd): Update to 7.3.0p1.
[inputs]: Replace openssl with now-working libressl.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 35360ba12e..d194d33934 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3175,20 +3175,20 @@ from the Cyrus IMAP project.")
 (define-public opensmtpd
   (package
     (name "opensmtpd")
-    (version "7.3.0p0")
+    (version "7.3.0p1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.opensmtpd.org/archives/"
                            "opensmtpd-" version ".tar.gz"))
        (sha256
-        (base32 "1rnaa022pkdc15vkvlisv42dvcxchib40h0m97myfyqjralabmrd"))))
+        (base32 "01ss6j1jadnd3ckgf9zpvrbdpipkf7m4l3isribqfwy2l50wsihv"))))
     (build-system gnu-build-system)
     (inputs
      (list bdb
            libevent
+           libressl
            linux-pam
-           openssl                      ; XXX recommended libressl segfaults
            zlib))
     (native-inputs
      (list bison groff))               ; for man pages