summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-05 06:58:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-05 07:03:11 +0200
commit4cd05788b548d60154f365542fd9446ac4bcfd9f (patch)
treed14e5f730bacce473bedfd45994fef1ad9ec272f /gnu
parent77986a6a99e7c283bdd2b3df93f666e6a166767c (diff)
downloadguix-4cd05788b548d60154f365542fd9446ac4bcfd9f.tar.gz
gnu: links: Enable framebuffer (fb) graphics driver.
* gnu/packages/web-browsers.scm (links)[native-inputs]:
Add linux-libre-headers.
[inputs]: Add gpm.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web-browsers.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index d31648257f..2ef09d49c9 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -55,6 +55,7 @@
   #:use-module (gnu packages image)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libidn)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages lisp)
   #:use-module (gnu packages lisp-xyz)
   #:use-module (gnu packages lua)
@@ -187,8 +188,10 @@ older or slower computers and embedded systems.")
                        (string-append "--prefix=" out)
                        "--enable-graphics")
                #t))))))
-    (native-inputs `(("pkg-config" ,pkg-config)))
-    (inputs `(("libevent" ,libevent)
+    (native-inputs `(("linux-libre-headers" ,linux-libre-headers)
+                     ("pkg-config" ,pkg-config)))
+    (inputs `(("gpm" ,gpm)
+              ("libevent" ,libevent)
               ("libjpeg" ,libjpeg-turbo)
               ("libpng" ,libpng)
               ("libtiff" ,libtiff)