summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-01 00:53:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-01 00:53:12 +0200
commit4d6350c212e6788c9eff477d6d02f81c311e50ff (patch)
treebd23f40a4b09280bb36ab546d4036171f144f6da /gnu
parent19450a62c6a67fce79f6e391ce18a5194b4352a9 (diff)
downloadguix-4d6350c212e6788c9eff477d6d02f81c311e50ff.tar.gz
gnu: emacs-git-timemachine: Update to 4.13.
* gnu/packages/emacs-xyz.scm (emacs-git-timemachine): Update to 4.13.
[source]: Remove ".git" suffix.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 18 insertions, 21 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6c1525b86f..27fc79ca60 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6012,28 +6012,25 @@ saving won't move point back to the beginning of the buffer.")
     (license license:gpl3+)))
 
 (define-public emacs-git-timemachine
-  (let ((version "4.11")
-        (revision "0")
-        (commit "13769fb603ae88c64566529eae4525ce88026e86"))
-    (package
-      (name "emacs-git-timemachine")
-      (version (git-version version revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://codeberg.org/pidu/git-timemachine.git")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0d1aj9xhcyksg115xl2yw0rd62hp53ig06y54jvii1l8vavb94jy"))))
-      (build-system emacs-build-system)
-      (home-page "https://gitlab.com/pidu/git-timemachine")
-      (synopsis "Step through historic versions of Git-controlled files")
-      (description "This package enables you to step through historic versions
+  (package
+    (name "emacs-git-timemachine")
+    (version "4.13")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://codeberg.org/pidu/git-timemachine")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "152vq34dn76m21ab97wwm31hgp2wl9y437vwmd4kcd5pvwjhx9c6"))))
+    (build-system emacs-build-system)
+    (home-page "https://gitlab.com/pidu/git-timemachine")
+    (synopsis "Step through historic versions of Git-controlled files")
+    (description "This package enables you to step through historic versions
 of files under Git version control from within Emacs.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-minitest
   (package