summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-06-05 22:22:56 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:54:07 +0200
commit4e36c8a07ba419ba1ab95e0dc6cc99bdd920e49e (patch)
treec140a042c914e9a80ff46ab5069cfca6053be4c2 /gnu
parentd3ed745e4704fba1ef74c95363acd9a3f99b88f7 (diff)
downloadguix-4e36c8a07ba419ba1ab95e0dc6cc99bdd920e49e.tar.gz
gnu: Add sysprof.
* gnu/packages/gnome.scm (sysprof): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bf5f71e1c2..cbb69e1fd6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -261,6 +261,55 @@ Desktop.  It is designed to be as simple as possible and has some unique
 features to enable users to create their discs easily and quickly.")
     (license license:gpl2+)))
 
+(define-public sysprof
+  (package
+    (name "sysprof")
+    (version "3.36.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "mirror://gnome/sources/" name "/"
+                       (version-major+minor version) "/"
+                       name "-" version ".tar.xz"))
+       (sha256
+        (base32 "024i0gzqnm79rpr4gqxdvcj6gvf82xdlcp2p1k9ikcppmi6xnw46"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t    ; To wrap binaries and/or compile schemas.
+       #:configure-flags
+       (list
+        ;; SystemD not required.
+        "-Dsystemdunitdir=/tmp")))
+    (native-inputs
+     `(("desktop-file-utils" ,desktop-file-utils)
+       ("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")
+       ("gobject-introspection" ,gobject-introspection)
+       ("gtk+:bin" ,gtk+ "bin")
+       ("itstool" ,itstool)
+       ("pkg-config" ,pkg-config)
+       ("xmllint" ,libxml2)))
+    (inputs
+     `(("libdazzle" ,libdazzle)
+       ("libunwind" ,libunwind)
+       ("pango" ,pango)
+       ("polkit" ,polkit)))
+    (propagated-inputs
+     `(("glib" ,glib)
+       ("gtk+" ,gtk+)))
+    (synopsis "Kernel based performance profiler")
+    (description "Sysprof is a sampling profiler that uses a kernel module to
+generate stacktraces which are then interpreted by the userspace program
+sysprof.")
+    (home-page "https://wiki.gnome.org/Apps/Sysprof")
+    (license
+     (list
+      ;; For newer codes.
+      license:gpl3+
+      ;; For older codes.
+      license:gpl2+))))
+
 (define-public gnome-photos
   (package
     (name "gnome-photos")