summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:09 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:14 +0100
commit4e5c1d4f0af2a2bb3cfa3a232e02239203918c4e (patch)
treef2622a68dac4aee87fc6a0b9668bdabd016d49f9 /gnu
parent6dec34e25bcd190d6698aa19869b0fb56ceb503a (diff)
downloadguix-4e5c1d4f0af2a2bb3cfa3a232e02239203918c4e.tar.gz
gnu: Add node-readable-stream.
* gnu/packages/node-xyz.scm (node-readable-stream): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node-xyz.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index e8932aeebc..58fdc1dc33 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -453,6 +453,55 @@ strings so that the decoded string does not contain incomplete multibyte
 sequences.")
     (license license:expat)))
 
+(define-public node-readable-stream
+  (package
+    (name "node-readable-stream")
+    (version "3.6.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nodejs/readable-stream")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0ybl4cdgsm9c5jq3xq8s01201jk8w0yakh63hlclsfbcdfqhd9ri"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies `("@babel/cli"
+                                    "@babel/core"
+                                    "@babel/polyfill"
+                                    "@babel/preset-env"
+                                    "airtap"
+                                    "assert"
+                                    "bl"
+                                    "deep-strict-equal"
+                                    "events.once"
+                                    "glob"
+                                    "gunzip-maybe"
+                                    "hyperquest"
+                                    "lolex"
+                                    "nyc"
+                                    "pump"
+                                    "rimraf"
+                                    "tap"
+                                    "tape"
+                                    "tar-fs"
+                                    "util-promisify")))))
+       #:tests? #f))
+    (inputs (list node-util-deprecate node-string-decoder node-inherits))
+    (home-page "https://github.com/nodejs/readable-stream")
+    (synopsis "Node.js core streams for userland")
+    (description
+     "@code{readable-stream} provides an implementation of Node.js core streams
+that behaves the same across different versions.")
+    (license license:expat)))
+
 (define-public node-irc-colors
   (package
     (name "node-irc-colors")