summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-02 12:15:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-02 15:04:55 +0200
commit4eddc221b39c43085584d9bb1620360c4a1f3139 (patch)
tree0c43c8bbd27b813b2973c74929892102aa63bdb8 /gnu
parent80ef8ff7ed1aaed47cabbf14e2b6daa663fc51cd (diff)
downloadguix-4eddc221b39c43085584d9bb1620360c4a1f3139.tar.gz
gnu: gtkd: Update to 3.10.0.
* gnu/packages/dlang.scm (gtkd): Update to 3.10.0.
[arguments]: Rename 'prepare-x phase to 'pre-check, set CC for the
tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/dlang.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index d605067864..77283adbed 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -413,14 +413,14 @@ needed.")
 (define-public gtkd
   (package
     (name "gtkd")
-    (version "3.9.0")
+    (version "3.10.0")
     (source
      (origin
       (method url-fetch/zipbomb)
       (uri (string-append "https://gtkd.org/Downloads/sources/GtkD-"
                           version ".zip"))
       (sha256
-       (base32 "0qv8qlpwwb1d078pnrf0a59vpbkziyf53cf9p6m8ms542wbcxllp"))))
+       (base32 "0vc5ssb3ar02mg2pngmdi1xg4qjaya8332a9mk0sv97x6b4ddy3g"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("unzip" ,unzip)
@@ -446,10 +446,11 @@ needed.")
                ;; Work around upstream bug.
                (("\\$\\(prefix\\)\\/\\$\\(libdir\\)") "$(libdir)"))
              #t))
-         (add-before 'check 'prepare-x
+         (add-before 'check 'pre-check
            (lambda _
              (system "Xvfb :1 &")
              (setenv "DISPLAY" ":1")
+             (setenv "CC" ,(cc-for-target))
              #t)))))
     (home-page "https://gtkd.org/")
     (synopsis "D binding and OO wrapper of GTK+")