summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-07-24 19:06:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-07-24 21:29:10 +0200
commit4f20e0a2f629249cb751824cc85a719ebd4bf4bf (patch)
treeca7aab299e926a44d0d2b74f86fac17076026805 /gnu
parent7e2c050a88ef92ab32be5e7612f059f5be46ce3f (diff)
downloadguix-4f20e0a2f629249cb751824cc85a719ebd4bf4bf.tar.gz
gnu: spice-gtk: Update to 0.37.
* gnu/packages/spice.scm (spice-gtk): Update to 0.37.
[propagated-inputs]: Use latest spice-protocol.
(spice-protocol-0.12): Remove unused variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/spice.scm21
1 files changed, 4 insertions, 17 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 1e9dfadf02..4787f107f0 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
 ;;;
@@ -115,23 +115,10 @@ which allows users to view a desktop computing environment.")
     (home-page "https://www.spice-space.org")
     (license (list license:bsd-3 license:lgpl2.1+))))
 
-(define-public spice-protocol-0.12
-  (package
-    (inherit spice-protocol)
-    (version "0.12.15")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://www.spice-space.org/download/releases/"
-                    "spice-protocol-" version ".tar.bz2"))
-              (sha256
-               (base32
-                "06b461i4jv741in8617jjpfk28wk7zs9p7841njkf4sbm8xv4kcb"))))))
-
 (define-public spice-gtk
   (package
     (name "spice-gtk")
-    (version "0.36")
+    (version "0.37")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -139,7 +126,7 @@ which allows users to view a desktop computing environment.")
                 "spice-gtk-" version ".tar.bz2"))
               (sha256
                (base32
-                "1kfpixfdmxs9wn3id48gc9bvfrgxz935y3wpykf40bgi9mcc69ki"))))
+                "1drvj8y35gnxbnrxsipwi15yh0vs9ixzv4wslz6r3lra8w3bfa0z"))))
     (build-system gnu-build-system)
     (propagated-inputs
       `(("gstreamer" ,gstreamer)
@@ -148,7 +135,7 @@ which allows users to view a desktop computing environment.")
         ("gst-plugins-good" ,gst-plugins-good)
         ("gst-plugins-bad" ,gst-plugins-bad)
         ("gst-plugins-ugly" ,gst-plugins-ugly)
-        ("spice-protocol" ,spice-protocol-0.12)
+        ("spice-protocol" ,spice-protocol)
 
         ;; These are required by the pkg-config files.
         ("gtk+" ,gtk+)