summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:42:17 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commit4f4afb63c7094b6b95ea19e2d84bf5342be1dabb (patch)
treef5f982a55880029cf5c0e5ef56a7b20f5e9216a8 /gnu
parent7a150b4d745900abde2ca31a86ededf37496dd27 (diff)
downloadguix-4f4afb63c7094b6b95ea19e2d84bf5342be1dabb.tar.gz
gnu: kde-frameworks: Add ki18n.
* gnu/packages/kde-frameworks.scm (ki18n): New variable.

Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 1ccb8ea192..4d9d18eae8 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -27,6 +27,7 @@
   #:use-module (guix utils)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -485,6 +486,48 @@ infrastructure.")
 interfaces in the areas of colors, fonts, text, images, keyboard input.")
     (license (list license:gpl2+ license:lgpl2.1+))))
 
+(define-public ki18n
+  (package
+    (name "ki18n")
+    (version "5.24.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://kde/stable/frameworks/"
+                            (version-major+minor version) "/"
+                            name "-" version ".tar.xz"))
+        (sha256
+         (base32
+          "0cw24spmwsqa3ppkw03cm6yjd3sfll0dbbk2ya76fd4nw9hb00dv"))))
+    (build-system cmake-build-system)
+    (propagated-inputs
+     `(("gettext" ,gnu-gettext)
+       ("python" ,python)))
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtscript" ,qtscript)))
+    (arguments
+     `(#:phases
+        (modify-phases %standard-phases
+          (add-before 'check 'check-setup
+            (lambda* _
+              (setenv "HOME" (getcwd)))))))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "KDE Gettext-based UI text internationalization")
+    (description "KI18n provides functionality for internationalizing user
+interface text in applications, based on the GNU Gettext translation system.  It
+wraps the standard Gettext functionality, so that the programmers and translators
+can use the familiar Gettext tools and workflows.
+
+KI18n provides additional functionality as well, for both programmers and
+translators, which can help to achieve a higher overall quality of source and
+translated text.  This includes argument capturing, customizable markup, and
+translation scripting.")
+    (license license:lgpl2.1+)))
+
 (define-public kwindowsystem
   (package
     (name "kwindowsystem")