summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 18:32:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:32:27 +0100
commit4fc898dad9cc22c3f5059c42c5fbdd7919205354 (patch)
treea2766e1553c0381d9a51a3472e7d70880aeef455 /gnu
parent38ec0f6adc3d84988a10b88df33a03d409bd8fc5 (diff)
downloadguix-4fc898dad9cc22c3f5059c42c5fbdd7919205354.tar.gz
gnu: python-numpy-documentation: Use INVOKE.
* gnu/packages/python-xyz.scm (python-numpy-documentation)[arguments]:
Use INVOKE instead of SYSTEM*.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae1b2e4062..89988822f8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3001,12 +3001,12 @@ color scales, and color space conversion easy.  It has support for:
                (with-directory-excursion "doc"
                  (copy-recursively sphinx-theme-checkout scipy-sphinx-theme)
                  (mkdir-p html)
-                 (system* "make" "html" pyver)
-                 (system* "make" "latex" "PAPER=a4" pyver)
-                 (system* "make" "-C" "build/latex"
+                 (invoke "make" "html" pyver)
+                 (invoke "make" "latex" "PAPER=a4" pyver)
+                 (invoke "make" "-C" "build/latex"
                           "all-pdf" "PAPER=a4" pyver)
                  ;; FIXME: Generation of the info file fails.
-                 ;; (system* "make" "info" pyver)
+                 ;; (invoke "make" "info" pyver)
                  ;; (mkdir-p info)
                  ;; (copy-file "build/texinfo/numpy.info"
                  ;;            (string-append info "/numpy.info"))