summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:29 +0200
commit5240a2136dbba8b1b426bbda4120275102d0dbd9 (patch)
treec648f716201fc1cac5855f331a3ea53dec100b43 /gnu
parent15ac6dd8102182b5effa30149645dc8f8d37d06c (diff)
downloadguix-5240a2136dbba8b1b426bbda4120275102d0dbd9.tar.gz
gnu: Add texlive-subeqn.
* gnu/packages/tex.scm (texlive-subeqn): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d2c2a8f3d5..d45179fa89 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96700,6 +96700,29 @@ document and may be typeset separately.  What the package does is sharing the
 @file{.aux} files.")
     (license license:expat)))
 
+(define-public texlive-subeqn
+  (package
+    (name "texlive-subeqn")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/subeqn/" "source/latex/subeqn/"
+                   "tex/latex/subeqn/")
+             (base32
+              "0x58m2lsjc8d3m673g59cxw3a81cj5699cd8vvps1fly0fsl5azb")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/subeqn")
+    (synopsis "Package for subequation numbering")
+    (description
+     "Sometimes it is necessary to be able to refer to subexpressions of an
+equation.  In order to do that these subexpressions should be numbered.  In
+standard LaTeX there is no provision for this.  The @code{subeqn} package
+solves this.  Note that this package is not compatible with the package
+@code{subeqnarray}, but it can be used together with the LaTeX class options
+@code{leqno} and @code{fleqn}.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar