summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndre A. Gomes <andremegafone@gmail.com>2024-01-09 10:35:53 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-01-10 10:53:01 +0100
commit537768018ee03a6a9a5562022a16b47ac287d131 (patch)
tree3cdf238e08bb88b3ae329056115aaa73f5ed75b1 /gnu
parentd34fe100186bbd680e1c470794b9232b105688b5 (diff)
downloadguix-537768018ee03a6a9a5562022a16b47ac287d131.tar.gz
gnu: Add cl-stripe.
* gnu/packages/lisp-xyz.scm (sbcl-stripe): New variable.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Change-Id: Ideeff671b8577bcfceb241a86624ac26f1d077f7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index a82e3b0827..5b9613fc05 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6134,6 +6134,38 @@ BTCPay, Paypal, and Stripe.")
 (define-public ecl-lisp-pay
   (sbcl-package->ecl-package sbcl-lisp-pay))
 
+(define-public sbcl-stripe
+  (let ((commit "b59631d21d63e101de6eb96b56941471504ba644")
+        (revision "0"))
+    (package
+      (name "sbcl-stripe")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/atlas-engineer/stripe")
+               (commit commit)))
+         (file-name (git-file-name "cl-stripe" version))
+         (sha256
+          (base32 "00sfq2f6dnpwa6pf7rgw5hazbwx4yf1g0jrkfz9h4kq5zyxwk1cy"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       (list sbcl-dexador
+             sbcl-golden-utils
+             sbcl-local-time
+             sbcl-yason))
+      (home-page "https://github.com/atlas-engineer/stripe")
+      (synopsis "Stripe payment API client for Common Lisp")
+      (description "A client for the Stripe payment API.")
+      (license license:expat))))
+
+(define-public cl-stripe
+  (sbcl-package->cl-source-package sbcl-stripe))
+
+(define-public ecl-stripe
+  (sbcl-package->ecl-package sbcl-stripe))
+
 (define-public sbcl-drakma
   (package
     (name "sbcl-drakma")