summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authoriKaSeRo <ahmed@ikasero.com>2021-09-05 14:31:02 +0300
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-06 00:16:51 +0200
commit53ccbc175570c4fd16b499670d37b36328d30f94 (patch)
tree9efacc7a34eb7d646c7a18cf5949943cdf695056 /gnu
parentdd7df191b6c8c3bbbece31b6946018dbaef553b4 (diff)
downloadguix-53ccbc175570c4fd16b499670d37b36328d30f94.tar.gz
gnu: Add mlterm.
* gnu/packages/terminals.scm (mlterm): New variable.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/terminals.scm47
1 files changed, 45 insertions, 2 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 1cdf0e1831..478b30eddf 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -25,6 +25,7 @@
 ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
+;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -66,6 +67,7 @@
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages fribidi)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
@@ -388,6 +390,47 @@ combining, and so on, with a simple interface.")
     (home-page "http://www.leonerd.org.uk/code/libtermkey")
     (license license:expat)))
 
+(define-public mlterm
+  (package
+    (name "mlterm")
+    (version "3.9.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/mlterm/01release/mlterm-"
+                           version "/mlterm-" version ".tar.gz"))
+       (sha256
+        (base32 "03fnynwv7d1aicwk2rp31sgncv5m65agvygqvsgn59v9di40gnnb"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:configure-flags
+       (list (string-append "--prefix=" (assoc-ref %outputs "out"))
+             "--disable-static"
+             "--enable-optimize-redrawing"
+             "--with-imagelib=gdk-pixbuf")))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cairo" ,cairo)
+       ("fontconfig" ,fontconfig)
+       ("freetype" ,freetype)
+       ("fribidi" ,fribidi)
+       ("gdk-pixbuf" ,gdk-pixbuf)
+       ("gtk+" ,gtk+)
+       ("libx11" ,libx11)
+       ("libxext" ,libxext)
+       ("libxft" ,libxft)))
+    (home-page "http://mlterm.sourceforge.net/")
+    (synopsis "Multi-Lingual TERMinal emulator")
+    (description
+     "mlterm is a multi-lingual terminal emulator.  It supports various complex
+character sets and encodings from around the world.  It can display double-width
+(e.g.  East Asian) glyphs, combining characters used for, e.g., Thai and
+Vietnamese, and bi-directional scripts like Arabic and Hebrew.")
+    (license license:bsd-3)))
+
 (define-public picocom
   (package
     (name "picocom")
@@ -1430,8 +1473,8 @@ terminal.  Note that you need support for OpenGL 3.2 or higher.")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                     (url "https://github.com/wtarreau/bootterm")
-                     (commit (string-append "v" version))))
+                    (url "https://github.com/wtarreau/bootterm")
+                    (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32