summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:19 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:33 +0200
commit53e466ad5f5c89979e3fd72fd38145333d55a53a (patch)
tree28612f1b62c4e082dc5248a285e44fd1f7e05b57 /gnu
parente0cab7495db63a69b7d13e9df693841985904ee1 (diff)
downloadguix-53e466ad5f5c89979e3fd72fd38145333d55a53a.tar.gz
gnu: password-utils: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation.

* gnu/packages/password-utils.scm
(shroud)[inputs]: Likewise.
(assword)[inputs]: Likewise.
(password-store)[inputs]: Likewise.
(pass-age)[inputs]: Likewise.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: I6400ef2a53f9ffe7c5e6690069f58e6a54bf3af6
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/password-utils.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index b684eb60f3..ebfe54dacb 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -410,10 +410,8 @@ client, supporting @acronym{TOTP, Time-based one time passwords} and
                                              "/lib/guile/" effective "/site-ccache"))
                     (prog      (string-append out "/bin/shroud")))
                (wrap-program prog
-                 `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))
-               #t))))))
-    (inputs
-     (list guile-2.2 gnupg xclip))
+                 `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))))))))
+    (inputs (list bash-minimal guile-2.2 gnupg xclip))
     (synopsis "GnuPG-based secret manager")
     (description "Shroud is a simple secret manager with a command line
 interface.  The password database is stored as a Scheme s-expression and
@@ -620,8 +618,7 @@ command-line programs (@command{pwqcheck}, @command{pwqfilter}, and
                                      "/bin/assword"))
                    (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
                (wrap-program prog
-                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))
-               #t)))
+                 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))))
          (add-after 'install 'manpage
            (lambda* (#:key outputs #:allow-other-keys)
              (invoke "make" "assword.1")
@@ -632,7 +629,7 @@ command-line programs (@command{pwqcheck}, @command{pwqfilter}, and
     (native-inputs
      (list txt2man))
     (inputs
-     (list gtk+ python-xdo python-gpg python-pygobject))
+     (list bash-minimal gtk+ python-xdo python-gpg python-pygobject))
     (propagated-inputs
      (list xclip))
     (home-page "https://finestructure.net/assword/")
@@ -725,7 +722,8 @@ any X11 window.")
             (separator #f)             ;single entry
             (files '("lib/password-store/extensions")))))
     (inputs
-     (list coreutils
+     (list bash-minimal
+           coreutils
            dmenu
            util-linux
            git
@@ -800,7 +798,7 @@ through the pass command.")
          ("src/completion/pass.zsh-completion"
           "/share/zsh/site-functions/"))))
     (inputs
-     (list age age-keygen git procps qrencode sed tree util-linux))
+     (list age age-keygen bash-minimal git procps qrencode sed tree util-linux))
     (home-page "https://github.com/FiloSottile/passage")
     (synopsis "Encrypted password manager")
     (description "This package provides an encrypted password manager, forked