summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-12 11:25:35 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-02 22:27:39 +0800
commit543032a888c9811d2e84d1eee59de8279f141ec2 (patch)
tree897e3ed6bf50b45bf2fd68f8efd7d781c373c5ce /gnu
parentacfa0bde84426aafbc9dd2993ab3b45baeb18c1f (diff)
downloadguix-543032a888c9811d2e84d1eee59de8279f141ec2.tar.gz
gnu: kcoreaddons: Use G-expressions.
* gnu/packages/kde-frameworks.scm (kcoreaddons)[arguments]:
Rewrite as G-expressions.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 7539e9807e..fe88629243 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -632,26 +632,27 @@ propagate their changes to their respective configuration files.")
     (build-system cmake-build-system)
     (native-inputs
      (list extra-cmake-modules qttools-5 shared-mime-info))
-           ;; TODO: FAM: File alteration notification http://oss.sgi.com/projects/fam
+    ;; TODO: FAM: File alteration notification http://oss.sgi.com/projects/fam
     (inputs
      (list qtbase-5))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'blacklist-failing-test
-           (lambda _
-             ;; Blacklist failing tests.
-             (with-output-to-file "autotests/BLACKLIST"
-               (lambda _
-                 ;; FIXME: Make it pass.  Test failure caused by stout/stderr
-                 ;; being interleaved.
-                 (display "[test_channels]\n*\n")
-                 ;; FIXME
-                 (display "[test_inheritance]\n*\n")))))
-         (add-before 'check 'check-setup
-           (lambda _
-             (setenv "HOME" (getcwd))
-             (setenv "TMPDIR" (getcwd)))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'blacklist-failing-test
+            (lambda _
+              ;; Blacklist failing tests.
+              (with-output-to-file "autotests/BLACKLIST"
+                (lambda _
+                  ;; FIXME: Make it pass.  Test failure caused by stout/stderr
+                  ;; being interleaved.
+                  (display "[test_channels]\n*\n")
+                  ;; FIXME
+                  (display "[test_inheritance]\n*\n")))))
+          (add-before 'check 'check-setup
+            (lambda _
+              (setenv "HOME" (getcwd))
+              (setenv "TMPDIR" (getcwd)))))))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Qt addon library with a collection of non-GUI utilities")
     (description "KCoreAddons provides classes built on top of QtCore to