summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-10 23:14:25 +0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-12 08:29:36 -0400
commit54372b289a549bf9fa0f1954b9ef084045cf7e39 (patch)
treef51898cf2244f1eee998213ec7fedf8814cb5c6e /gnu
parent4736de9de4678c35cd9670c0b4333336aed52cd2 (diff)
downloadguix-54372b289a549bf9fa0f1954b9ef084045cf7e39.tar.gz
gnu: ijs: Fix cross-building to riscv64-linux.
* gnu/packages/ghostscript.scm (ijs)[arguments]: When building for
riscv64-linux replace config.guess and config.sub.
[native-inputs]: When building for riscv64-linux add config.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ghostscript.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 55f3ab9364..dfd43d8ed0 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2013, 2015, 2016, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2017, 2018, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2019, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
@@ -313,7 +313,10 @@ output file formats and printers.")
    (source (package-source ghostscript))
    (build-system gnu-build-system)
    (native-inputs
-    (list libtool automake autoconf))
+    (append (if (target-riscv64?)
+              (list config)
+              '())
+            (list libtool automake autoconf)))
    (arguments
     `(#:phases
       (modify-phases %standard-phases
@@ -331,7 +334,17 @@ output file formats and printers.")
             (substitute* "autogen.sh"
               (("^.*\\$srcdir/configure.*") "")
               (("^ + && echo Now type.*$")  ""))
-            (invoke "bash" "autogen.sh"))))))
+            (invoke "bash" "autogen.sh")))
+        ,@(if (target-riscv64?)
+            `((add-after 'unpack 'update-config-scripts
+                (lambda* (#:key native-inputs inputs #:allow-other-keys)
+                  (for-each (lambda (file)
+                              (install-file
+                               (search-input-file
+                                (or native-inputs inputs)
+                                (string-append "/bin/" file)) "ijs"))
+                            '("config.guess" "config.sub")))))
+            '()))))
    (synopsis "IJS driver framework for inkjet and other raster devices")
    (description
     "IJS is a protocol for transmission of raster page images.  This package