summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-10 00:29:05 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-10 00:32:22 +0100
commit54a114db45b37a6664bffd4ec9d4aa0c6bafeb48 (patch)
tree25394fa9d7ea77a04482033261a48ba5987fe80a /gnu
parentd8ba3987a01d54a1ea1a729fa18e42448c9a541d (diff)
downloadguix-54a114db45b37a6664bffd4ec9d4aa0c6bafeb48.tar.gz
gnu: babl: Update to 0.1.72.
* gnu/packages/gimp.scm (babl): Update to 0.1.72.
[build-system]: Switch to Meson.
[arguments]: Disable GObject introspection.
[native-inputs]: Add pkg-config.
[propagated-inputs]: Add lcms.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gimp.scm21
1 files changed, 15 insertions, 6 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 70bc8db4c1..4fd3cd0167 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -29,6 +29,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
+  #:use-module (guix build-system meson)
   #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages autotools)
@@ -49,22 +50,30 @@
 (define-public babl
   (package
     (name "babl")
-    (version "0.1.66")
+    (version "0.1.72")
     (source (origin
               (method url-fetch)
               (uri (list (string-append "https://download.gimp.org/pub/babl/"
                                         (version-major+minor version)
-                                        "/babl-" version ".tar.bz2")
+                                        "/babl-" version ".tar.xz")
                          (string-append "https://ftp.gtk.org/pub/babl/"
                                         (version-major+minor version)
-                                        "/babl-" version ".tar.bz2")
+                                        "/babl-" version ".tar.xz")
                          (string-append "ftp://ftp.gtk.org/pub/babl/"
                                         (version-major+minor version)
-                                        "/babl-" version ".tar.bz2")))
+                                        "/babl-" version ".tar.xz")))
               (sha256
                (base32
-                "0qx1dwbinxihwl2lmxi60qiqi402jlrdcnixx14kk6j88n9xi79n"))))
-    (build-system gnu-build-system)
+                "0hkagjrnza77aasa1kss5hvy37ndm50y6i7hkdn2z8hzgc4i3qb4"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:configure-flags
+       (list "-Denable-gir=false")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     ;; Propagated to satisfy ‘babl.pc’.
+     `(("lcms" ,lcms)))
     (home-page "http://gegl.org/babl/")
     (synopsis "Image pixel format conversion library")
     (description