summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-13 22:36:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-13 23:09:23 +0100
commit54b431b7b38c6148ee24b64e86bbbf1d57361584 (patch)
tree9683ea05c62d177f050a269a5fbb5c0ea7fba549 /gnu
parent7260cc75daef53bae508e738206fd55bb75ea177 (diff)
downloadguix-54b431b7b38c6148ee24b64e86bbbf1d57361584.tar.gz
gnu: fastp: Simplify.
* gnu/packages/bioinformatics.scm (fastp)[arguments]: Simplify gexp.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 265697d625..4e16b0d39a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5337,15 +5337,16 @@ The main functions of FastQC are:
          "0ly8mxdvrcy23jwxyppysx3dhb1lwsqhfbgpyvargxhfk6k700x4"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ; there are none
-       #:make-flags
-       ,#~(list (string-append "PREFIX=" #$output))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (add-before 'install 'create-target-dir
-           (lambda* (#:key outputs #:allow-other-keys)
-             (mkdir-p (string-append (assoc-ref outputs "out") "/bin")))))))
+     (list
+      #:tests? #false                   ;there are none
+      #:make-flags
+      #~(list (string-append "PREFIX=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (add-before 'install 'create-target-dir
+            (lambda _
+              (mkdir-p (string-append #$output "/bin")))))))
     (inputs
      (list zlib))
     (home-page "https://github.com/OpenGene/fastp/")