summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2013-03-06 20:58:48 +0000
committerNikita Karetnikov <nikita@karetnikov.org>2013-03-06 20:58:48 +0000
commit563e8b3920e67e0ac9297f4fd3165084c8844654 (patch)
tree58aa2dec324b465c95de3e5c444028c5578bb15e /gnu
parentbd5ecea63754b2dbc0c142ae11d9d11716fd703a (diff)
downloadguix-563e8b3920e67e0ac9297f4fd3165084c8844654.tar.gz
gnu: Add GNU Fdisk.
* gnu/packages/fdisk.scm: New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fdisk.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/fdisk.scm b/gnu/packages/fdisk.scm
new file mode 100644
index 0000000000..5cf02a9014
--- /dev/null
+++ b/gnu/packages/fdisk.scm
@@ -0,0 +1,54 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages fdisk)
+  #:use-module ((guix licenses) #:select (gpl3+))
+  #:use-module ((gnu packages gettext)
+                #:renamer (symbol-prefix-proc 'guix:))
+  #:use-module (gnu packages guile)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages parted)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public fdisk
+  (package
+    (name "fdisk")
+    (version "2.0.0a")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/fdisk/gnufdisk-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "04nd7civ561x2lwcmxhsqbprml3178jfc58fy1v7hzqg5k4nbhy3"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("gettext" ,guix:gettext)
+       ("guile" ,guile-1.8)
+       ("util-linux" ,util-linux)
+       ("parted" ,parted)))
+    (home-page "https://www.gnu.org/software/fdisk/")
+    (synopsis
+     "GNU Fdisk, a command-line disk partitioning tool")
+    (description
+     "GNU Fdisk provides alternatives to util-linux fdisk and util-linux
+cfdisk.  It uses GNU Parted.")
+    (license gpl3+)))
\ No newline at end of file