summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:18 +0200
commit569eeaac78def9b50c1996fcc04c88ad88217bff (patch)
tree38679cee278b20c743f7782cbaf56bce4707a140 /gnu
parent401e9905258f4976b74f79f485d13648aa67bdb4 (diff)
downloadguix-569eeaac78def9b50c1996fcc04c88ad88217bff.tar.gz
gnu: Add texlive-snotez.
* gnu/packages/tex.scm (texlive-snotez): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 281500307f..74b0bd93f7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96095,6 +96095,26 @@ other so they never overlap; the lines never overlap either.  Aesthetic and
 customizable style.")
     (license license:lppl1.3c)))
 
+(define-public texlive-snotez
+  (package
+    (name "texlive-snotez")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/snotez/" "tex/latex/snotez/")
+             (base32
+              "075aj3lbmqsvsj0vpq79zbdl64ghcym47k2kc6ijfad2k9ygijbm")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/snotez")
+    (synopsis "Typeset notes, in the margin")
+    (description
+     "The package provides a macro @code{\\sidenote}, that places a note in the
+margin of the document, with its baseline aligned with the baseline in the
+body of the document.  These sidenotes are numbered (both in the text, and on
+the notes themselves).")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar