summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-09-09 16:41:50 +0200
committerRoel Janssen <roel@gnu.org>2020-09-09 16:41:50 +0200
commit57add3d0fc5bbd6f73e9b7a137882daf2aed3bc2 (patch)
tree67553cce9b9e3a52d4bcf8b13a37b8cd198216dd /gnu
parentd165d77f8552587f2aefb5e259406e1a8e9548cb (diff)
downloadguix-57add3d0fc5bbd6f73e9b7a137882daf2aed3bc2.tar.gz
gnu: Add r-partykit.
* gnu/packages/cran.scm (r-partykit): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2c202e8508..a3f3809fe0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1933,6 +1933,32 @@ of space-time series.  The @code{pastecs} library is a PNEC-Art4 and IFREMER
 initiative to bring PASSTEC 2000 functionalities to R.")
    (license license:gpl2+)))
 
+(define-public r-partykit
+  (package
+   (name "r-partykit")
+   (version "1.2-9")
+   (source (origin
+             (method url-fetch)
+             (uri (cran-uri "partykit" version))
+             (sha256
+              (base32
+               "18nc6vvj1cy8ly2hqixg544sbg8vbpzwsr1cdlzrqfykd0pzgkvf"))))
+   (build-system r-build-system)
+   (propagated-inputs
+    `(("r-formula" ,r-formula)
+      ("r-inum" ,r-inum)
+      ("r-libcoin" ,r-libcoin)
+      ("r-mvtnorm" ,r-mvtnorm)
+      ("r-rpart" ,r-rpart)
+      ("r-survival" ,r-survival)))
+   (home-page "http://partykit.R-Forge.R-project.org/partykit")
+   (synopsis "Toolkit for recursive partytioning")
+   (description
+    "This package provides a toolkit with infrastructure for representing,
+summarizing, and visualizing tree-structured regression and classification
+models.")
+   (license license:gpl2+)))
+
 (define-public r-plogr
   (package
     (name "r-plogr")