summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-08 12:29:24 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-08 12:29:42 +0200
commit580f33e119820c6005fa2453f3405135b75e66e3 (patch)
tree33e4da88ed63b1bf1c38c5b212fb1e29eb8788cc /gnu
parent49fe965d28d497f234b032e9a170fb0b503d0204 (diff)
downloadguix-580f33e119820c6005fa2453f3405135b75e66e3.tar.gz
gnu: criu: Update to 3.11.
* gnu/packages/virtualization.scm (criu): Update to 3.11.
[arguments]: Add custom phase to patch python calls.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/virtualization.scm25
1 files changed, 19 insertions, 6 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index be3c3aaa76..57c5c34da1 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -656,14 +656,14 @@ domains, their live performance and resource utilization statistics.")
 (define-public criu
   (package
     (name "criu")
-    (version "3.7")
+    (version "3.11")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://download.openvz.org/criu/criu-"
                                   version ".tar.bz2"))
               (sha256
                (base32
-                "0qrpz7pvnks34v7d8lb73flz3mb7qwnib94pdwaxh0mskn8470fq"))))
+                "03nimyn3wy5mlw30gq7bvlzvvprqjv8f25240yj5arzlld8mhsw8"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
@@ -681,9 +681,6 @@ domains, their live performance and resource utilization statistics.")
                      (string-append (assoc-ref inputs "libnl")
                                     "/include/libnl3:"
                                     (getenv "C_INCLUDE_PATH")))
-             ;; Hardcode arm version detection
-             (substitute* "Makefile"
-               (("ARMV.*:=.*") "ARMV := 7\n"))
              ;; Prevent xmlto from failing the install phase.
              (substitute* "Documentation/Makefile"
                (("XMLTO.*:=.*")
@@ -695,7 +692,23 @@ domains, their live performance and resource utilization statistics.")
                                (assoc-ref inputs "docbook-xsl")
                                "/xml/xsl/docbook-xsl-"
                                ,(package-version docbook-xsl)
-                               "/manpages/docbook.xsl")))
+                               "/manpages/docbook.xsl"))
+               (("\\$\\(XMLTO\\);")
+                (string-append (assoc-ref inputs "xmlto")
+                               "/bin/xmlto;")))
+             #t))
+         (add-after 'unpack 'hardcode-variables
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; Hardcode arm version detection
+             (substitute* "Makefile"
+               (("ARMV.*:=.*") "ARMV := 7\n"))
+             ;; We are currently using python-2
+             (substitute* "crit/Makefile"
+               (("\\$\\(PYTHON\\)") "python2"))
+             (substitute* "lib/Makefile"
+               (("\\$\\(PYTHON\\)")
+                (string-append (assoc-ref inputs "python")
+                               "/bin/python")))
              #t))
          (add-before 'build 'fix-symlink
            (lambda* (#:key inputs #:allow-other-keys)