summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-08-21 00:33:53 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-01 13:44:36 +0200
commit58974e7b1971c9795ab6365b8e80e5140ceba9e5 (patch)
tree05d772f92e1a26992d54de64f39f3c1a6eec1e40 /gnu
parent3bf5a19609560c7ba985eda66019eda15aaf4a86 (diff)
downloadguix-58974e7b1971c9795ab6365b8e80e5140ceba9e5.tar.gz
gnu: python-tox: Build with tests.
* gnu/packages/python-check.scm (python-tox)[arguments]: Convert to list of
G-Expressions.  Drop #:tests?.  Add #:phases.
[native-inputs]: Add python-flaky, python-pathlib2, python-pytest-freezegun,
and python-pytest-timeout.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm46
1 files changed, 41 insertions, 5 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index dc2e474c34..5ee1d41f34 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2300,9 +2300,42 @@ which make writing and running functional and integration tests easier.")
          "0nk0nyzhzamcrvn0qqzzy54isxxqwdi28swml7a2ym78c3f9sqpb"))))
     (build-system python-build-system)
     (arguments
-     ;; FIXME: Tests require pytest-timeout, which itself requires
-     ;; pytest>=2.8.0 for installation.
-     '(#:tests? #f))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "pytest" "-vv" "-k"
+                        (string-join
+                         (map (lambda (test)
+                                (string-append "not test_" test))
+                              '("invocation_error"
+                                "create_KeyboadInterrupt"
+                                "exit_code"
+                                "tox_get_python_executable"
+                                "find_alias_on_path"
+                                "get_executable"
+                                "get_executable_no_exist"
+                                "get_sitepackagesdir_error"
+                                "spinner_stdout_not_unicode"
+                                "provision_non_canonical_dep"
+                                "package_setuptools"
+                                "package_poetry"
+                                "parallel_interrupt"
+                                "provision_missing"
+                                "provision_from_pyvenv"
+                                "provision_interrupt_child"
+                                "create"
+                                "run_custom_install_command"
+                                "toxuone_env"
+                                "different_config_cwd"
+                                "test_usedevelop"
+                                "build_backend_without_submodule"
+                                "parallel"
+                                "parallel_live"
+                                "tox_env_var_flags_inserted_isolated"))
+                         " and "))))))))
     (propagated-inputs
      (list python-filelock
            python-packaging
@@ -2312,8 +2345,11 @@ which make writing and running functional and integration tests easier.")
            python-toml
            python-virtualenv))
     (native-inputs
-     (list ; FIXME: Missing: ("python-pytest-timeout" ,python-pytest-timeout)
-           python-pytest ; >= 2.3.5
+     (list python-flaky
+           python-pathlib2
+           python-pytest                ; >= 2.3.5
+           python-pytest-freezegun
+           python-pytest-timeout
            python-setuptools-scm))
     (home-page "https://tox.readthedocs.io")
     (synopsis "Virtualenv-based automation of test activities")