summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2017-06-17 15:58:05 +0800
committerJan Nieuwenhuizen <janneke@gnu.org>2017-06-30 23:30:31 +0200
commit58addd2b20d7ae41f30dc3b0e87b303c7a6f9aa2 (patch)
tree018b91c2a01f2e6558e33a8093d106f15bd72b45 /gnu
parente3ddb1e83296c10338d35bc687772242b2f5eac6 (diff)
downloadguix-58addd2b20d7ae41f30dc3b0e87b303c7a6f9aa2.tar.gz
gnu: Add emacs-switch-window.
* gnu/packages/emacs.scm (emacs-switch-window): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 42060dcc5d..a335abdb3d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4635,6 +4635,27 @@ It should enable you to implement low-level X11 applications.")
 built on top of XELB.")
     (license license:gpl3+)))
 
+(define-public emacs-switch-window
+  (package
+    (name "emacs-switch-window")
+    (version "1.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/dimitri/switch-window/archive/v"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0xyxqrw71krdnj3sdm4x05zw7n40h075s262jih75vmrix95sjlj"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/dimitri/switch-window")
+    (synopsis "Emacs window switch tool")
+    (description "Switch-window is an emacs window switch tool, which
+offer a visual way to choose a window to switch to, delete, split or
+other operations.")
+    (license license:wtfpl2)))
+
 (define-public emacs-gnuplot
   (package
     (name "emacs-gnuplot")