summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2021-01-16 17:52:27 +0000
committerLeo Famulari <leo@famulari.name>2021-02-01 19:54:35 -0500
commit5b5915560e5cbd546c005a950515f6d293442a28 (patch)
treefb51c12c953fe10b5bc094302fc76924982ed744 /gnu
parent60a5071f60b1287967196d98c434dbe136e2d6ac (diff)
downloadguix-5b5915560e5cbd546c005a950515f6d293442a28.tar.gz
gnu: Add zplugins.
* gnu/packages/music.scm (zplugins): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm37
1 files changed, 21 insertions, 16 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 0da4cdd73a..f8b93ae41a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5932,34 +5932,39 @@ hall reverb and a room reverb.  Both are available as LV2 plugins as well
 as JACK standalone applications.")
     (license license:gpl3+)))
 
-(define-public zlfo
+(define-public zplugins
   (package
-    (name "zlfo")
-    (version "0.1.3")
+    (name "zplugins")
+    (version "0.1.7")
     (source
      (origin
        (method git-fetch)
-       (uri (git-reference
-             (url "https://git.zrythm.org/git/ZLFO")
-             (commit (string-append "v" version))))
+       (uri
+        (git-reference
+         (url "https://git.zrythm.org/git/zplugins")
+         (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0bm466ci5xyvxvq7l9p6xyh789lvk6i31b4zja1igqh13akbjnjz"))))
+         "1rkm2xajmyik6289b20rp5a5br9f3sh1xk8nb1bs6qpmcrfirgbs"))))
     (build-system meson-build-system)
     (inputs
-     `(("librsvg" ,librsvg)
-       ("lv2" ,lv2)
-       ("ztoolkit-rsvg" ,ztoolkit-rsvg)))
+      `(("guile" ,guile-2.2)
+        ("libsndfile" ,libsndfile)
+        ("lv2" ,lv2)
+        ("ztoolkit-rsvg" ,ztoolkit-rsvg)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
-    (synopsis "Low frequency oscillator plugin")
-    (description "ZLFO is a fully featured
-@dfn{low frequency oscillator} (LFO) for @dfn{control voltage} (CV)-based
-automation that comes as an LV2 plugin bundle with a custom UI.")
-    (home-page "https://git.zrythm.org/cgit/ZLFO/")
+      `(("pkg-config" ,pkg-config)))
+    (synopsis "Audio plugin collection")
+    (description "ZPlugins is a collection of audio DSP plugins intended
+to be bundled with the Zrythm @dfn{digital audio workstation} (DAW).")
+    (home-page "https://www.zrythm.org/en/plugins.html")
     (license license:agpl3+)))
 
+(define-public zlfo
+  ;; The "zlfo" package is now included in zplugins
+  (deprecated-package "zlfo" zplugins))
+
 (define-public remid-lv2
   (package
     (name "remid-lv2")