summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-25 09:55:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:58:41 +0200
commit5b83710671912df02e052bf0095b5a0bbe103498 (patch)
tree76fda4ffae4a6c62e839a667d529a220f1b0f55a /gnu
parent9f5ab70c03e2437d3e6643196cab834f827f4aba (diff)
downloadguix-5b83710671912df02e052bf0095b5a0bbe103498.tar.gz
gnu: Add rust-lru-0.9.
* gnu/packages/crates-io.scm (rust-lru-0.9): New variable.
(rust-lru-0.7): Inherit from rust-lru-0.9.

Change-Id: I930762a081e9511eef6e18498bb27e15e6d1dbcc
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 24 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 979a63eb52..63eef347bd 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -41134,23 +41134,20 @@ image together with its neighboring pixels.")
         ("rust-rayon" ,rust-rayon-1)
         ("rust-time" ,rust-time-0.2))))))
 
-(define-public rust-lru-0.7
+(define-public rust-lru-0.9
   (package
     (name "rust-lru")
-    (version "0.7.2")
+    (version "0.9.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "lru" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "07sdl7gpg30hbz7cgph75n2xl8915rshi90c7jqr5j9mi62m6hr7"))))
+        (base32 "05yz4qqx7wxbhgxs5hx22j13g8mv9z3gn2pkspykyq48winx9rvi"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs
-       (("rust-hashbrown" ,rust-hashbrown-0.11))
+     `(#:cargo-inputs (("rust-hashbrown" ,rust-hashbrown-0.13))
        #:cargo-development-inputs
        (("rust-scoped-threadpool" ,rust-scoped-threadpool-0.1)
         ("rust-stats-alloc" ,rust-stats-alloc-0.1))))
@@ -41159,6 +41156,25 @@ image together with its neighboring pixels.")
     (description "This package provides a LRU cache implementation.")
     (license license:expat)))
 
+(define-public rust-lru-0.7
+  (package
+    (inherit rust-lru-0.9)
+    (name "rust-lru")
+    (version "0.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "lru" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "07sdl7gpg30hbz7cgph75n2xl8915rshi90c7jqr5j9mi62m6hr7"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-hashbrown" ,rust-hashbrown-0.11))
+       #:cargo-development-inputs
+       (("rust-scoped-threadpool" ,rust-scoped-threadpool-0.1)
+        ("rust-stats-alloc" ,rust-stats-alloc-0.1))))))
+
 (define-public rust-lru-cache-0.1
   (package
     (name "rust-lru-cache")