summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHendursaga <hendursaga@aol.com>2023-09-25 13:48:43 -0400
committerChristopher Baines <mail@cbaines.net>2023-09-27 12:08:02 +0100
commit5c3e4c826f35a7eaace878b1782dd3cb66bd74fa (patch)
treee6258c1f06770b8813fc8daea40a5dc18fbd16cf /gnu
parentd05af1dbaf84166e0f92e65d42bc75507033d41c (diff)
downloadguix-5c3e4c826f35a7eaace878b1782dd3cb66bd74fa.tar.gz
gnu: lhasa: Update to 0.4.0.
* gnu/packages/compression.scm (lhasa): Update to 0.4.0.
[arguments]: Use G-expressions.
[home-page]: Switch to github.io.
[description]: Add Texinfo markup.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm35
1 files changed, 17 insertions, 18 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index beaac3fccb..43e02b895d 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -542,7 +542,7 @@ than gzip and 15 % smaller output than bzip2.")
 (define-public lhasa
   (package
     (name "lhasa")
-    (version "0.3.1")
+    (version "0.4.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -550,26 +550,25 @@ than gzip and 15 % smaller output than bzip2.")
                     version "/lhasa-" version ".tar.gz"))
               (sha256
                (base32
-                "092zi9av18ma20c6h9448k0bapvx2plnp292741dvfd9hmgqxc1z"))))
+                "1cy5429c7h1dp4l5y9ncdy40qarl9ix31ylkzdi8al2c60y8iz57"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'set-up-test-environment
-           (lambda* (#:key inputs #:allow-other-keys)
-             (setenv "TZDIR"
-                     (search-input-directory inputs
-                                             "share/zoneinfo")))))))
-    (native-inputs
-     (list tzdata-for-tests))
-    (home-page "https://fragglet.github.com/lhasa/")
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-before 'check 'set-up-test-environment
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (setenv "TZDIR"
+                                    (search-input-directory inputs
+                                                            "share/zoneinfo")))))))
+    (native-inputs (list tzdata-for-tests))
+    (home-page "https://fragglet.github.io/lhasa/")
     (synopsis "LHA archive decompressor")
-    (description "Lhasa is a replacement for the Unix LHA tool, for
-decompressing .lzh (LHA / LHarc) and .lzs (LArc) archives.  The backend for the
-tool is a library, so that it can be reused for other purposes.  Lhasa aims to
-be compatible with as many types of lzh/lzs archives as possible.  It also aims
-to generate the same output as the (non-free) Unix LHA tool, so that it will
-act as a free drop-in replacement.")
+    (description
+     "Lhasa is a replacement for the Unix LHa tool, for decompressing
+@file{.lzh} (LHA / LHarc) and .lzs (LArc) archives.  The backend for the tool is
+a library, so that it can be reused for other purposes.  Lhasa aims to be
+compatible with as many types of @file{.lzh}/@file{lzs} archives as possible.
+It also aims to generate the same output as the (non-free) Unix @command{lha}
+tool, so that it will act as a free drop-in replacement.")
     (license license:isc)))
 
 (define-public lzo