summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-18 23:36:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-22 18:56:35 +0200
commit5c7952fbf4b56684412b4c5e0751e4076e4f23da (patch)
tree138db3aca26a917c7efad23fa8cbd58a41374651 /gnu
parente7a5d73ea9fb0eee5c7e116674e347849711f863 (diff)
downloadguix-5c7952fbf4b56684412b4c5e0751e4076e4f23da.tar.gz
gnu: ant: Move after bootstrap packages.
* gnu/packages/java.scm (ant): Move package.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm94
1 files changed, 47 insertions, 47 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 238841aa9d..abb2f62add 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -701,53 +701,6 @@ the standard javac executable.  The tool runs on JamVM instead of SableVM.")))
        ("jamvm" ,jamvm)
        ("classpath" ,classpath-devel)))))
 
-(define-public ant
-  (package (inherit ant-bootstrap)
-    (name "ant")
-    ;; The 1.9.x series is the last that can be built with GCJ.  The 1.10.x
-    ;; series requires Java 8.
-    (version "1.9.9")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://apache/ant/source/apache-ant-"
-                                  version "-src.tar.gz"))
-              (sha256
-               (base32
-                "1k28mka0m3isy9yr8gz84kz1f3f879rwaxrd44vdn9xbfwvwk86n"))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  (for-each delete-file
-                            (find-files "lib/optional" "\\.jar$"))
-                  #t))))
-    (arguments
-     (substitute-keyword-arguments (package-arguments ant-bootstrap)
-       ((#:phases phases)
-        `(modify-phases ,phases
-           (add-after 'unpack 'remove-scripts
-             ;; Remove bat / cmd scripts for DOS as well as the antRun and runant
-             ;; wrappers.
-             (lambda _
-               (for-each delete-file
-                         (find-files "src/script"
-                                     "(.*\\.(bat|cmd)|runant.*|antRun.*)"))
-               #t))
-           (replace 'build
-             (lambda _
-               (setenv "JAVA_HOME" (string-append (assoc-ref %build-inputs "gcj")
-                                                  "/lib/jvm"))
-               ;; Disable tests to avoid dependency on hamcrest-core, which needs
-               ;; Ant to build.  This is necessary in addition to disabling the
-               ;; "check" phase, because the dependency on "test-jar" would always
-               ;; result in the tests to be run.
-               (substitute* "build.xml"
-                 (("depends=\"jars,test-jar\"") "depends=\"jars\""))
-               (zero? (system* "bash" "bootstrap.sh"
-                               (string-append "-Ddist.dir="
-                                              (assoc-ref %outputs "out"))))))))))
-    (native-inputs
-     `(("gcj" ,gcj)))))
-
 ;; The bootstrap JDK consisting of jamvm, classpath-devel,
 ;; ecj-javac-on-jamvm-wrapper-final cannot build Icedtea 2.x directly, because
 ;; it's written in Java 7.  It can, however, build the unmaintained Icedtea
@@ -1692,6 +1645,53 @@ IcedTea build harness.")
 (define-public icedtea icedtea-7)
 
 
+(define-public ant
+  (package (inherit ant-bootstrap)
+    (name "ant")
+    ;; The 1.9.x series is the last that can be built with GCJ.  The 1.10.x
+    ;; series requires Java 8.
+    (version "1.9.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://apache/ant/source/apache-ant-"
+                                  version "-src.tar.gz"))
+              (sha256
+               (base32
+                "1k28mka0m3isy9yr8gz84kz1f3f879rwaxrd44vdn9xbfwvwk86n"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  (for-each delete-file
+                            (find-files "lib/optional" "\\.jar$"))
+                  #t))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments ant-bootstrap)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (add-after 'unpack 'remove-scripts
+             ;; Remove bat / cmd scripts for DOS as well as the antRun and runant
+             ;; wrappers.
+             (lambda _
+               (for-each delete-file
+                         (find-files "src/script"
+                                     "(.*\\.(bat|cmd)|runant.*|antRun.*)"))
+               #t))
+           (replace 'build
+             (lambda _
+               (setenv "JAVA_HOME" (string-append (assoc-ref %build-inputs "gcj")
+                                                  "/lib/jvm"))
+               ;; Disable tests to avoid dependency on hamcrest-core, which needs
+               ;; Ant to build.  This is necessary in addition to disabling the
+               ;; "check" phase, because the dependency on "test-jar" would always
+               ;; result in the tests to be run.
+               (substitute* "build.xml"
+                 (("depends=\"jars,test-jar\"") "depends=\"jars\""))
+               (zero? (system* "bash" "bootstrap.sh"
+                               (string-append "-Ddist.dir="
+                                              (assoc-ref %outputs "out"))))))))))
+    (native-inputs
+     `(("gcj" ,gcj)))))
+
 (define-public clojure
   (let* ((remove-archives '(begin
                              (for-each delete-file