summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-06 19:55:29 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-06 19:56:05 +0000
commit5dee582c135f4e3e639b8b2a9d502037053075d9 (patch)
tree81274f377b694f0662e09212084eaa71311c3518 /gnu
parentac18dfc675cd289c28bc312ae9d859e358a30107 (diff)
downloadguix-5dee582c135f4e3e639b8b2a9d502037053075d9.tar.gz
gnu: python-pynrrd: Update to 1.0.0.
* gnu/packages/python-science.scm (python-pynrrd): Update to 1.0.0.
[arguments]: Keep 'ensure-no-mtimes-pre-1980 phase as it's building with
it successfully.
[propagated-inputs]: Add python-nptyping and python-typing-extensions.

Change-Id: Ic4dcd0825e71d3eb4acd39694bee9e22e8485f9f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-science.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 3b3faecde2..30547e9cbe 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2603,7 +2603,7 @@ Providers}.")
 (define-public python-pynrrd
   (package
     (name "python-pynrrd")
-    (version "0.4.3")
+    (version "1.0.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2612,13 +2612,10 @@ Providers}.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "12vlgx2k7jxbq9r9maiix4dbk8alixa0il420bqwhzln08s3chz1"))))
+                "09gdyi4kbi3512ydgqxkgr4j7b9a95qh83fk2n9s41bns4id9xj7"))))
     (build-system python-build-system)
-    (arguments
-     (list #:phases
-           #~(modify-phases %standard-phases
-               (delete 'ensure-no-mtimes-pre-1980))))
-    (propagated-inputs (list python-numpy))
+    (propagated-inputs
+     (list python-nptyping python-numpy python-typing-extensions))
     (home-page "https://github.com/mhe/pynrrd")
     (synopsis "Python module for reading and writing NRRD files")
     (description