summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-02-08 13:36:55 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-08 17:07:52 +0100
commit5e686e0a2c9bdf33ee24e978b7fe2134ba66d3de (patch)
treeaa9c217db17d53a85cf9cf2ba418f3ac9d85aa24 /gnu
parent48650b0c3569222d53d29320ba97343dc4ef8038 (diff)
downloadguix-5e686e0a2c9bdf33ee24e978b7fe2134ba66d3de.tar.gz
gnu: qgis: Disable SAGA.
QGIS support for SAGA is currently not working.

* gnu/packages/geo.scm (qgis)[inputs]: Remove saga.
  [arguments]: Remove PATH wrapping for saga.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/geo.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5eaa9e14c0..afda0a8971 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2152,8 +2152,11 @@ growing set of geoscientific methods.")
              #t))
          (add-after 'wrap-qt 'wrap-gis
            (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; TODO: Find if there is a way to get SAGA to work.
+             ;; Currently QGIS says "version of SAGA not supported".
+             ;; Disable it for now.
              (let* ((out (assoc-ref outputs "out"))
-                    (saga (string-append (assoc-ref inputs "saga") "/bin"))
+                    ;;(saga (string-append (assoc-ref inputs "saga") "/bin"))
                     (grass-version ,(package-version grass))
                     (grass-majorminor (string-join
                                        (list-head
@@ -2162,7 +2165,7 @@ growing set of geoscientific methods.")
                     (grass (string-append (assoc-ref inputs "grass")
                                           "/grass" grass-majorminor)))
                (wrap-program (string-append out "/bin/qgis")
-                 `("PATH" ":" prefix (,saga))
+                 ;;`("PATH" ":" prefix (,saga))
                  `("QGIS_PREFIX_PATH" = (,out))
                  `("GISBASE" = (,grass))))
              #t)))))
@@ -2209,7 +2212,7 @@ growing set of geoscientific methods.")
        ("qtsvg" ,qtsvg)
        ("qtwebkit" ,qtwebkit)
        ("qwt" ,qwt)
-       ("saga" ,saga)
+       ;;("saga" ,saga)
        ("sqlite" ,sqlite)))
     (native-inputs
      `(("bison" ,bison)