summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-03-20 17:00:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-20 18:25:10 +0100
commit628c22ec9e635b42608d9aa396fa12fb4f38a493 (patch)
tree4695c9b62e0e7b278e2b46b642ce1a32cb98dd1f /gnu
parent9f09ac6b218e8538028394ce0aec4b6a8c479f54 (diff)
downloadguix-628c22ec9e635b42608d9aa396fa12fb4f38a493.tar.gz
gnu: Add r-tkrplot.
* gnu/packages/cran.scm (r-tkrplot): New variable.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 39e692fc6c..b69d4ac2c5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2818,6 +2818,27 @@ designed to make it easy to install and load multiple tidyverse packages in a
 single step.")
     (license license:gpl3)))
 
+(define-public r-tkrplot
+  (package
+    (name "r-tkrplot")
+    (version "0.0-27")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "tkrplot" version))
+       (sha256
+        (base32 "19bj4wn1fs4wrx5k4gakhpz4q59fgx0584wyaw7hnh0ljj8i34n9"))))
+    (properties `((upstream-name . "tkrplot")))
+    (build-system r-build-system)
+    (inputs (list libx11))
+    (home-page "https://cran.r-project.org/package=tkrplot")
+    (synopsis "Place R graphics in a Tk widget")
+    (description
+     "The tkrplot package lets you place R graphics in a @dfn{Tk,
+cross-platform graphical user interface toolkit} widget.")
+    ;; Any version of the GPL.
+    (license (list license:gpl2+ license:gpl3+))))
+
 (define-public r-rvest
   (package
     (name "r-rvest")